Einleitung

Navigation: »Keine Übergeordneten Themen verfügbar«

Einleitung

 Zurück zur StartSeite

Jede Festplatte wird zu klein, wenn man nur lange genug wartet. TreeSize Free kann Ihnen sagen, wo ihr wertvoller Festplattenplatz geblieben ist. Es kann aus dem Kontextmenü eines Ordners oder Laufwerks aufgerufen werden und zeigt die Größe dieses Verzeichnisses inklusive aller Unterverzeichnisse an.

Man kann sich außerdem in einer Explorer-ähnlichen Darstellung die Größe einzelner Unterverzeichnisse oder den durch das Dateisystem verschwendeten Platz anschauen. Das Scannen der Festplatte geschieht im Hintergrund, Sie können sich also schon Teilergebnisse anschauen, während das Programm noch arbeitet. Die Ergebnisse können in einem Report ausgedruckt werden.


Installation

Installation

Führen Sie das Installationsprogramm aus und folgen Sie den Anweisungen. TreeSize Free kann über die Systemsteuerung wieder deinstalliert werden. Unterstützte Betriebssysteme sind Windows XP, Windows 2003 Server, Windows Vista, Windows Servedr 2008, Windows Server 2008 R2, Windows 7, inklusive der 64Bit Versionen. Neben einem normalen Installer wird auch eine ZIP-Datei mit TreeSize Free zur Verfügung gestellt, die ihre Einstellungen lokal speichert und so beispielsweise auf einem USB-Stick verwendet werden kann.


Tipps & Anmerkungen

Tipps & Anmerkungen

Die folgenden Hinweise sind sehr wichtig. Hier werden Information und Anweisungen zur Verfügung gestellt, die den Gebrauch und das Verstehen von TreeSize Free einfacher machen.

· Der Windows Explorer zeigt den physisch auf dem Laufwerk belegten Platz an während TreeSize den Platz anzeigt, den alle Dateien und Verzeichnisse zusammen unterhalb eines bestimmten Pfades belegen. Über den Platz für Dateien und Verzeichnisse hinaus wird auf einem Laufwerk noch zusätzlicher Platz zum Ablegen von Verwaltungsinformationen benötigt, wie z.B. die Dateibelegungstabelle (FAT) oder der Boot Sektor. Hierfür werden üblicherweise rund 0,5 - 2% des Platzes einer Partition benötigt. Eine andere Möglichkeit für die Abweichung kann die Verwendung von Software RAID sein, wie es beispielsweise Windows NT/2000 bietet. RAID verteilt die Daten auf mehrere Festplatten, die im System aber wie ein einzelnes Laufwerk erscheinen. Häufig werden die Daten redundant gespeichert, so dass der Ausfall einer einzelnen Festplatte zu keinem Datenverlust führt. Allerdings benötigt das Speichern der redundanten Informationen zusätzlichen Platz auf den Festplatten. Durch fehlende Leserechte kann es ebenfalls dazu kommen, dass TreeSize bestimme Bereiche der Festplatte nicht lesen kann, so dass deren Größe am Ende in der Summe fehlt. TreeSize Professional kann aber durch einen Trick in der Regel auch diese Bereiche untersuchen.
· Alle Ordner, die im Fenster sichtbar sind, werden im gedruckten Report erfasst. Wenn Sie einen kompletten Report wünschen, wählen Sie den oberen Ordner aus und klicken Sie auf "TreeSize / Full Expand" im Kontextmenü.
· Sie können den Modus "CD/DVD Größe" benutzen, um festzustellen, wieviel Platz ein Verzeichnisbaum auf einer CD oder DVD benötigen würde.
· Um die Dateien eines Ordners anzuzeigen, klicken Sie im Kontextmenü des Ordners auf "Öffnen".
· Die "Filter" und "die benutzerdefinierten Clustergrößen" werden nicht gespeichert, um falsche Werte bei der nächsten Benutzung von TreeSize Free zu vermeiden.
· TreeSize Free zeigt deutschsprachige Menüs an, wenn in der Systemsteuerung "Deutsch" eingestellt ist.


TreeSize Professional / Personal

TreeSize Professional / Personal

Neben TreeSize Free gibt es auch noch TreeSize Professional und TreeSize Personal. Zusätzlich zu der Funktionalität von TreeSize Free, bieten diese Versionen viele weitere nützliche Funktionen:

· Zahlreiche Export- und Reportingmöglichkeiten: gedruckter Report, Excel, XML, HTML, Textdatei, Zwischenablage, E-Mail (Nur Professional Edition).
· Speichern Sie Scanergebnisse in einer XML-Datei, die Sie später wieder laden können.
· Eine gespeicherte XML-Datei kann zum Vergleich mit dem derzeitigen Stand des Dateisystems genutzt werden. Es wird dann die Differenz der beiden Scans angezeigt, was das Erkennen von stark gewachsenen Ordnern erleichtert.
· Generieren Sie Statistiken für Dateitypen, Benutzer und Dateialter. Die Daten in der Verzeichnisstruktur lassen sich außerdem auf einen Benutzer oder einen Dateityp einschränken.
· Top 100 Liste der größten Dateien.
· Hohe Performance durch Multithreading: Es können zur gleichen Zeit mehrere Verzeichnisbäume untersucht werden. Die Anzahl der Threads wird permanent und automatisch an die Prozerssoranzahl und Prozessorlast angepasst.
· Die Details (Größe, belegter Platz, verschwendeter Platz, Prozent, Anzahl Dateien) können auf einen Blick angeschaut werden.
· Die Spalten können in Abhängigkeit vom Ausgabe-Medium (Detail-Ansicht, ASCII-Datei, Excel, gedruckter Report) ausgewählt und sortiert werden.
· Es können 3D Balken- und Tortendiagramme, sowie ein hierarchisches Kacheldiagramm angezeigt und ausgedruckt werden.
· Der Inhalt eines Verzeichnisses kann inklusive aller Dateien und deren Icons ausgedruckt werden.
· Eine komplette Liste mit allen Dateien im untersuchten Verzeichniszweig kann exportiert werden.
· Leistungsfähige Dateisuche: Es kann in beliebig vielen Pfaden nach großen, alten, temporären oder Browser-Cache-Dateien gesucht werden.
· Eine Suche nach doppelten Dateien mit MD5-Prüfsummen ist ebenfalls enthalten.
· Eine benzuerdefinierte Dateisuche, in der die Suckriterien völlig frei gewählt werden können, ist ebenfalls enthalten.
· Die Ergebnisse der Dateisuche können exportiert, verschoben, gezippt, gelöscht oder als Parameter an ein ausführbares Programm übergeben werden.
· Kommandozeilen Optionen erlauben regelmäßige oder zeitgesteuerte Untersuchungen, z.B. über Nacht (Nur Professional Edition).
· Es können auch Verzeichnisse untersucht werden, auf die der aktuelle Benutzer keinen Zugriff hat.
· Ausführliche Deutsche Hilfe Datei und ein druckbares Handbuch.
· Und noch vieles mehr ...

Weiter Informationen, sowie eine Demoversion finden Sie unter: http://www.jam-software.de/treesize/


Was ist neu?

Was ist neu?

 Zurück zur StartSeite

Version 2.5.1: Veröffentlicht am 16. November 2010

· Die Geschwindigkeit beim Expandieren vieler Ordner über das neue Menü "Einblenden" wurde gesteigert, wenn dabei viele Dateien eingeblendet wurden.
· Der Fortschritt des Scans wird nun in der Windows 7 Taskleiste angezeigt.

Version 2.5: Veröffentlicht am 08. November 2010

· TreeSize Free kann nun die NTFS Kompressionsrate im Verzeichnisbaum anzeigen. Dies fügt TreeSize Free die Hauptfunktion unseres eingestellten Tools NTFSRatio hinzu.
· Eine neue Option erlaubt es, komprimierte Ordner in blauer Farbe darzustellen. Ordner, die nur teilweise komprimiert sind, werden in dunkelblau dargestellt.
· Es ist nun möglich, im Verzeichnisbaum Dateien und Ordner umzubenennen. Dies kann über das Kontextmenü oder die Taste F2 geschehen.
· Ein neuer Menüpunkt "Einblenden" im Hauptmenü und dem Kontextmenü des Wurzelverzeichnisses erlaubt das Aufklappen aller Unterordner bis zu einer bestimmten Ebene.
· Ein laufender Scan kann nun mittels "Datei > Scan abbrechen" angehalten werden.
· Die Anordnung der Menüpunkte im Hauptmenü wurde überarbeitet.
· Die Unterstützung für Windows 2000 wurde beendet, da Microsoft seinerseits die Unterstützung hierfür im Juli 2010 eingestellt hat. TreeSize Free V2.4, das noch kompatibel mit Windows 2000 ist, bleibt auf unserer Internetseite verfügbar.
· Weitere kleinere Verbesserungen wurden eingearbeitet.

Version 2.4: Veröffentlicht am 10. Februar 2010

· Unterstützung für Drag und Drop Operationen wurde hinzugefügt. Diese funktionieren sowohl innerhalb der Verzeichnisbaums als auch mit dem Windows Explorer.
· "Ansicht > Optionen > Datei-Filter" zeigt nun eine Dialogbox an, die das komfortable Anpassen des Filters erlaubt.
· Die Punkte "Neue Instanz von TreeSize Free (Ctrl+N)" und "Drucker einrichten" wurden dem "Datei"-Menü hinzugefügt.
· Der Menüpunkt "Mit TreeSize untersuchen" wurde dem Kontextmenü hinzugefügt. Er erlaubt das Starten einer neuen Instanz von TreeSize Free, deren Wurzelverzeichnis das aktuell selektierte Verzeichnis ist.
· Das Kontextmenü des Windows Explorers wird nun auch für die [Dateien] Elemente im Verzeichnisbaum angezeigt. Das angezeigte Kontextmenü wird dabei auf alle Dateien angewendet, die unter diesem Element zusammengefasst sind.
· Das Expandieren aller Elemente mit Hilfe des Kontextmenüs ist nun wesentlich schneller.
· Das Windows Start-Menü enthält nun einen Eintrag, der TreeSize Free unter Windows Vista und später mit administrativen Privilegien starten kann.
· Mit der neuen Option "Untersuchung mit nur einem Thread" unter "Ansicht > Optionen" kann TreeSize Free angewiesen werden, die Untersuchung des Verzeichniszweigs mit nur einem Thread vorzunehmen. Dies minimiert den Einfluss der Untersuchung auf die Performance Ihres Systems.
· Bugfix: Wenn eine selektierte Datei gelöscht und anschließend das übergeordnete Element zugeklappt wurde, konnte eine Fehlermeldung erscheinen.
· Bugfix: Die Einstellungen wurden bei der Deinstallation nicht korrekt vom System entfernt.

Version 2.3.3: Veröffentlicht am 03. Juli 2009

· Bugfix: Wenn eine einzelne Datei gelöscht wurde und anschließend der Ordner zugeklappt wurde, konnte ein Fehler auftreten falls zu diesem Zeitpunkt kein anderes Element selektiert war.
· Einige kleinere Verbesserungen sind eingeflossen.

Version 2.3.2: Veröffentlicht am 24. Juni 2009

· Bugfix: In einigen Fällen war das Wurzelverzeichnis in TreeSize nicht aufklappbar.

Version 2.3.1: Veröffentlicht am 18. Mai 2009

· Ordner ohne Unterordner sind jetzt ebenfalls aufklappbar und zeigen die Dateien an, genauso wie die [Dateien] Elemente.
· Weitere kleinere Verbesserungen sind eingeflossen.

Version 2.3: Veröffentlicht am 22. Apr 2009

· Die [Dateien] Elemente im Verzeichnisbaum können jetzt ebenfalls aufgeklappt werden und zeigen dann die einzelnen Dateien.
· Der Farbverlauf, der im Hintergrund jedes Ordners dessen Größe visualisiert, kann nun im Menü "Optionen" farblich angepasst werden.
· Die Anzahl der angezeigten Nachkommastellen kann nun im Menü "Ansicht" angepasst werden.
· Die Einstellungen werden nun in einer XML-Datei statt der Windows Registry gespeichert.
· TreeSize Free verwendet jetzt bis zu zwei Threads zum Scannen der Platte statt einem. Bei der Personal und Professional Edition ist die Anzahl der Threads nicht limitiert und wird während des Scans automatisch der Systembelastung angepasst.
· Bugfix: Wurde die Sortierung nach Ende des Scans verändert, so waren zu diesem Zeitpunkt nicht aufgeklappte Order nach dem Aufklappen nicht richtig sortiert.
· Die Geschwindigkeit der Scans wurde erhöht.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.

Version 2.2.1: Veröffentlicht am 19. Mai 2008

· Bugfix: Der Menüeintrag, der mit Hilfe von Ansicht / Optionen / TreeSize im Explorer Kontextmenü anzeigen erzeugt wurde, hat nicht funktioniert.
· Bugfix: Auf einigen Systemen funktionierte die Deinstallation nicht.

Version 2.2: Veröffentlicht am 9. Mai 2008

· TreeSize Free kann jetzt beim Scannen der Festplatte mit Pfaden umgehen, die aus mehr als 255 Zeichen bestehen.
· Die Kompatibilität mit 64Bit Systemen wurde verbessert.
· TreeSize Free zeigt nun optional einen langer Tooltip mit detaillierte Informationen zu jedem Ordner an (Ansicht / Optionen), sobald der Mauszeiger eine kurze Weile auf einem Ordner verweilt.
· TreeSize Free beinhaltet nun einen Option um den Kontextmenu Eintrag "TreeSize Free" im Windows Explorer nicht mehr anzuzeigen (Ansicht / Optionen). Dies ist nun eine Benutzer-bezogene Einstellung.
· Das Hilfe-System wurde von der "Liesmich.txt" auf ein HTML-basiertes Hilfe-System umgestellt.
· Weitere kleinere Korrekturen und Verbesserungen sind eingeflossen.
· Der Support für Windows 9x/ME wurde mit dieser Version eingestellt. Für Benutzer dieser Windows Versionen stellen wir weiterhin TreeSize Free V2.1 zur Verfügung.

Version 2.1: Veröffentlicht am 7. Mai 2007

· Mit der neuen Option 'Zeige Fehlermeldungen' (Optionen | Ansicht) können Sie nun auswählen, ob eine Fehlermeldung ausgegeben werden soll, wenn während des Scans ein Fehler auftrat (z.B. Zugriffsverweigerung beim Versuch, auf ein Verzeichnis zuzugreifen).
· Es wurde eine neue Schaltfläche der Toolbar hinzugefügt, die angewählte Verzeichnisse direkt im Windows Explorer öffnet.
· Der Dialog "Verzeichnis auswählen" (Datei | Verzeichnis auswählen) verfügt nun über eine Textbox, in der man das zu scannende Verzeichnis direkt eingeben kann, anstatt über den Verzeichnisbaum danach zu suchen.
· Der "[Dateien]" Knoten im Verzeichnisbaum bietet nun auch ein Kontextmenü mit dem Eintrag, den Ordner mit den ausgewählten Dateien direkt im Windows Explorer zu öffnen.
· Der Kontextmenüeintrag 'Zähle Ordner' wurde in 'Anzahl Unterordner' umbenannt und ist nun in allen gescannten Unterordnern verfügbar, nicht nur im Wurzelverzeichnis.
· Bug Fix: Wurde ein Wechseldatenträger gescannt, und TreeSize fand nach dem Restart heraus, dass der Datenträger nicht mehr verfügbar ist, wurde früher eine Fehlermeldung ausgegeben. Jetzt wird das fehlende Laufwerk einfach ignoriert.

Version 2.0: Veröffentlicht am 14. März 2007

· TreeSize Free wurde komplett umgeschrieben und verwendet denselben Quellcode, wie die neueste Version von TreeSize Professional.
· Scans werden viel nun viel schneller durchgeführt.
· Die Ansicht kann nun auch Dateigrößen in GB und die Anzahl der Dateien darstellen.
· Pfadangaben in Unicode werden nun unterstützt.
· Bei der Berechnung des zugewiesenen Speicherplatzes wird nun die NTFS-Komprimierung berücksichtigt.
· Die kleine Balkenanzeige für die Dateigröße wurde durch ein Balkendiagramm ersetzt.


Copyright & Kontakt

Copyright & Kontakt

TreeSize Free ist Freeware, d.h. Sie können TreeSize Free kostenlos nutzen und im unveränderten Zustand unentgeltlich weitergeben.

Copyright © 2010 Joachim Marder e.K.

JAM Software GmbH
Max-Planck-Str. 22
54296 Trier
Deutschland

FAX: | 0651-145653-29
WWW: | http://www.jam-software.de
Support: | http://www.jam-software.de/customers/contact.php
E-Mail: | treesize@jam-software.de
Handelsregister: | HRB 4920 (Amtsgericht Wittlich)
Umsatzsteuer ID: | DE234825349
Geschäftsführer: | Joachim Marder